초기 SSD를 제외하고 최근에 출시되는 SSD의 경우 여러 보안모드를 지원하고 있습니다.

하지만 보안모드로 인해 간혹 SSD 를 초기화 할때 잠겨있어 PSID 초기화를 통해 보안모드를 풀고 초기화를 해야 하는 경우가 있습니다.

그런데 문제는 PSID 초기화를 통해 보안모드를 풀었다가도 다시 또 잠기는 문제가 있습니다.

 

TCG 로 인해 보안모드로 잠겨 있을때 PSID Revert 실행시

(PSID 코드를 입력한뒤 초기화 하여야 한다고 함)

 

보안모드가 풀려 있을때 PSID Revert 실행시

 

이런 현상이 주로 윈도우 8 이상의 OS 에서 발생하는데 BitLocker 와 관련되어 잠기는 문제로 보입니다.

(정확한 원인은 알수 없고 시스템 마다 다르게 발생하는걸로 보이며)

(특히 AHCI 드라이버 나 연결된 SATA 포트로 인해 혹은 잦은 시스템 강제 종료로 인한 문제로 보고 있습니다.)

(외장하드를 사용하다 보면 생기는 BitLocker 로 잠기는 문제와 유사한 문제로 보고 있습니다.)

 

이를 방지(해결하기) 위해서는 아래의 방법이 있습니다.

1. PSID 초기화

2. 바이오스에서 디스크에 암호 설정

3. 윈도우 재설치

4. 디스크 파티션시 약 300MB 의 SRP 파티션 생성한뒤 OS 설치

5. 윈도우 설치중간에 TCGSecurityActivation 비활성화 한후 OS 설치

 

본문에서는 TCGSecurityActivation 을 비활성화에 대한 방법을 다루겠습니다.

(단, 이미 보안모드로 잠겨있다면 풀고 진행)

 

윈도우 설치 중간에 Shift + F10 키를 눌러 명령프롬프트에서 다음 명령어를 입력합니다.

 

 

Reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\EnhancedStorageDevices" /v TCGSecurityActivationDisabled /t REG_DWORD /d 1 /f

 

정상적으로 입력하고 실행한뒤

 

Reg query "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\EnhancedStorageDevices" /s

 

명령어를 통해 확인을 하면 정상적으로 TCGSecurityActivationDisabled 항목에 값이 0x1 으로 나오면 비활성화된 상태입니다.

 

이를 쉽게 하기 위해 배치파일을 첨부하오니 윈도우 설치 디스크에 넣고 off (비활성화) 명령어 입력후 check (비활성화 확인) 명령어를

통해 확인하신뒤 OS 설치를 계속 진행하시면 됩니다.

 

 

check.bat

off.bat

 

2015/03/20 - [OS/윈도우] - PSID Revert 초기화로 Crucial SSD 보안모드 풀기

 

참고할 사이트

http://answers.microsoft.com/en-us/windows/forum/windows8_1-hardware/sed-edrive-unprovisioning/87148920-e749-4e8a-b674-d8d8d551981d

http://forum.crucial.com/t5/Crucial-SSDs/M500-Issues-with-locking-up-A-TCG-Command-has-returned-an-error/td-p/149506

https://technet.microsoft.com/en-us/library/dn306081.aspx

http://www.r0m30.com/msed/documentation/managing/removeopal

저작자 표시 비영리 변경 금지
신고
  1. lakrut 2017.02.14 10:36 신고

    안녕하세요,
    요즘 이벤트 로그에 "TCG command has returned error" 가 계속 떠서 관련 정보 찾다가 들어오게 되었습니다.
    윈10 사용중이구요.. 크루셜 SSD를 사용 중인데, PSID를 초기화 시키고 다시 설치하면서 TCG 비활성화까지 했는데도
    설치 끝나고 재부팅해서 로그 확인하면 또 동일한 error 메세지가 뜹니다.. (윈도우 UEFI 설치와 관련은 없겠죠?)
    해결이 안되면 삼성SSD 구입해서 OS용으로 쓰고, 크루셜 제품은 데이터용으로 사용할까 싶은데,
    TCG 에러 뜨는 것이 OS를 설치해서 발생하는 것인지, 데이터 용으로 사용해도 동일한 에러가 뜨는 건지 궁금하네요..


    • Favicon of http://www.mvapple.com BlogIcon mvapple 2017.02.14 10:40 신고

      어떤 모델을 사용중이신지요(펌웨어 버전도 알려주세요)

    • lakrut 2017.02.14 10:45 신고

      M550, MX200 두 개 사용 중이고, 번갈아 PSID 초기화하고 윈도우도 양쪽에 설치해보면서 확인해봤는데 계속 동일한 에러 뜹니다. 펌웨어는 둘다 최신 버전으로 업데이트 되어 있구요.

    • Favicon of http://www.mvapple.com BlogIcon mvapple 2017.02.14 10:57 신고

      uefi 를 풀고 테스트해보셔야 할것 같습니다
      그러니까 uefi 방식으로 설치하지 마시고 legecy 방식으로 설치를 한다음에 테스트를 해보세요
      포럼에서 해결방법이 여럿있긴한데 두대의 다른 모델에서 동일 문제가 발생하는걸로 보아 바이오스 세팅쪽이나 드라이버쪽 문제 케이블 문제일수도 있으니 체크해 보시구요

  2. lakrut 2017.02.14 11:16 신고

    바이오스 세팅이라는 것은 어느 부분을 확인해야할까요??

    • Favicon of http://www.mvapple.com BlogIcon mvapple 2017.02.14 11:31 신고

      초기화를 한다음에 세팅을 다시해 보세요

    • lakrut 2017.02.14 12:05 신고

      다시 시도해봤습니다;;
      M550 분리 후
      MX200에 uefi로 윈도우 설치, 부팅하니 TCG 에러 안뜸-전원 끄고 M550 연결 후 다시 부팅-TCG 에러..
      다시 MX200 분리하고, M550 에 uefi로 윈도우 설치, 부팅하니 TCG 안뜸..
      아직 MX200 다시 연결은 못했는데, 두 SSD를 동시에 연결하면 TCG 에러가 뜨는 상황인 듯 합니다..

    • Favicon of http://www.mvapple.com BlogIcon mvapple 2017.02.14 12:09 신고

      메인보드 모델이 어떻게 되시나요?
      윈도우 설치하고 드라이버 설치는 하셨나요?
      간혹 rst 드라이버 버전에 따라 해당문제가 발생할수 있다고 하네요
      uefi 모드를 풀거나 시큐어부팅옵션이 켜져 있다면 끄고 진행해 보세요.
      tcg 쪽 문제로 펌웨어 업데이트 된 일부 모델이 있긴한데 해당 문제가 uefi 나 드라이버쪽 호환 문제로 보인다고 하는데
      완벽한 해결방법이 아닌지라..
      혹시 모르니 smart 체크도 해보세요

    • lakrut 2017.02.14 12:14 신고

      Asus rampage V Extreme 사용 중입니다.
      드라이버 설치 유무와 상관없이 발생하는데, legacy 설치 최후로 해보고 안되면 ssd를 하나만 사용해야죠;;

    • lakrut 2017.02.14 14:39 신고

      해결했습니다!
      정확히는 기억이 안나지만, M550은 PSID 초기화를 2번했고 MX200은 윈도우상에서 GPT로 변환 작업도 했고(분명 UEFI로 윈도우 설치해서 GPT로 되어있었을텐데 윈도우 상에 MBR로 뜨는게 이상하더군요..).. 그후에 개별 분리, 장착하면서 각각에 윈도우 설치해서 에러 안뜨는 것 확인.. 둘다 장착후 에러 안뜨는 것 확인.. 둘다 장착한 후에 파티션 모두 날리고 다시 UEFI로 윈도우 설치..해서 기본 드라이버까지 모두 잡아준 상태인데 아직까진 TCG 에러가 안뜨고 있습니다.. PSID 초기화가 제대로 안된 것인지, MBR, GPT 변환이 꼬였던 것인지 뭔지 모르겠지만, 암튼 도움 주셔서 감사합니다. 또다시 문제되는 일은 없겠죠;;

    • Favicon of http://www.mvapple.com BlogIcon mvapple 2017.02.14 15:13 신고

      해결되셨다니 다행입니다
      도움 드린것도 없는데요 ㅎㅎ

티스토리 툴바