이번 우분투의 새로운 버전이 공개되면서 여러가지 바뀐 부분이 있습니다.

커널 버전으로 시작 기본 아파치의 버전이 2.2.x 버전에서 2.4.x 버전으로 업데이트가 되었습니다.

 

그중 한가지 아파치의 가상호스트 설정 부분이 약간 바뀌었더군요..

 

개인적으로 간단히 테스트하는 서버라 일일이 컴파일해서 사용하지 않고 apt-get 으로 패키지 설치를 하는 편이라서 기존 버전에서

사용하던 가상호스트 설정파일을 그대로 유지를 했는데 여기에서 문제를 일으키더군요..

 

 

 

기존 방법이

Order allow,deny / Allow from all 이였다면 최신버전에서는 위와 같이 변경을 해주어야 정상적으로 작동하더군요

 

참고사이트

Upgrading to 2.4 from 2.2

저작자 표시 비영리
신고
  1. Favicon of http://www.homzzang.com BlogIcon 홈짱 2015.10.16 17:10 신고

    자세한 팁 고맙습니다.

    근데, 현재 2.2 사용 중인데, 2.4로 바로 업데이트 하려면 어떻게 해야 할까요?

    • Favicon of http://www.mvapple.com BlogIcon mvapple 2015.10.16 17:26 신고

      현재 상태에 따라 다를걸로 보입니다.
      저 같이 패키지로 설치된 경우 apt-get 으로 업데이트를 진행하신뒤
      가상호스트의 내용을 위 메뉴얼을 참고하시어 수정해주신뒤
      같이 연동된 모듈이 정상적으로 올라오는지 확인하시면 될것 같습니다.
      (주의 할건 운영중인 서비스에 문제가 생길 우려가 있으니 동일환경에서 구축 테스트해보셔야 합니다.)
      직접 컴파일 하신경우도 마찬가지인데 컴파일 옵션에서 기존 2.2 에서 설정한 설치경로와 기타 경로를 동일하게 설정하신뒤에 업데이트를 진행하시면 될것 같습니다.
      (마찬가지로 가상호스트 부분도 변경해주시고, 연동된 모듈이 정상적으로 올라오는지 확인하셔야 합니다.)
      (정상적으로 업데이트가 되었는데 서비스를 실행할수 없는 경우에는
      로그를확인하시어 문제가 발생한 부분을 수정하시면 될것 같습니다.)

티스토리 툴바